Users may experience long load times and delayed emails due to issues with third-party service providers
Incident Report for GiveGab
Resolved
Our third-party service providers are reporting that the issue has been resolved. We will continue to monitor for any issues.
Posted Dec 15, 2021 - 11:27 EST
Update
We are continuing to work on a fix for this issue.
Posted Dec 15, 2021 - 11:18 EST
Identified
Our third-party service providers are experiencing elevated errors that may lead to longer than normal load times or elevated error pages when navigating our applications.

Emails generated by GiveGab may be delayed until these issues are resolved.

We are actively monitoring these issues and will update this status as we learn more.
Posted Dec 15, 2021 - 11:17 EST
This incident affected: GiveGab Platform, GiveGab API, GiveGab Giving Day Platform, and Mandrill Mandrill Global.