GiveGab degraded performance from service provider
Incident Report for GiveGab
Resolved
Our service provider is fully operational. All emails should resume sending. We will continue to monitor for any extenuating issues.
Posted Mar 04, 2020 - 10:01 EST
Investigating
The service that we use to send GiveGab emails is currently experiencing downtime. Any emails generated through https://www.givegab.com or our giving day applications will not be delivered. Emails not delivered during this time will be sent once our service provider is fully operational.
Posted Mar 04, 2020 - 09:27 EST
This incident affected: GiveGab Platform, GiveGab Giving Day Platform, and Mandrill Mandrill Global.