Nonprofit Giving Day profiles not saving as expected
Incident Report for GiveGab
Resolved
Users should now be able to successfully update their nonprofit's giving day profiles. We will continue to monitor the platform for any issues.
Posted Apr 20, 2020 - 13:32 EDT
Identified
Changes to nonprofit giving day profiles are currently not being saved as expected. We have identified a fix and are in the process of getting it reviewed and tested.
Posted Apr 20, 2020 - 12:10 EDT
This incident affected: GiveGab Platform and GiveGab Giving Day Platform.